Is the COBI.Bike app compatible with the operating system of my smartphone?

You need a smartphone with operating system iOS 12 and higher or Android 6 and higher.

Any questions?
We're happy to help.

Contact us

Help Center

Any questions?
We're happy to help.

Contact us