Is the COBI.Bike app compatible with my smartphone's operating system?

COBI.Bike app
Produkt ändern

You need a smartphone with the iOS 12 operating system or higher or with Android 6 or higher.

Was this helpful?

Any questions?
We're happy to help.

Contact

Help Center

Any questions?
We're happy to help.

Contact