Why do I get "An app update required" message, although I've already installed the latest version of the eBike Flow app?

eBike Flow App
Change product

If you’re seeing this message, ensure your eBike Flow App is connected to your eBike.
Then go to  Settings > My eBike > eBike update > Check for eBike update.

Tell a friend

Share link

Was this helpful?

Any questions?
We're happy to help.

Contact us

Help Center

Any questions?
We're happy to help.

Contact us