I already connected my eBike to the eBike Flow App. However now on the Home Screen label it says my eBike is "Not connected". What can I do?

eBike Flow App
Change product

Please check the following:

1. Make sure to have your eBike and smartphone nearby and both devices are switched on.

2. Always make sure the eBike Flow app is running in the background. The app doesn't require significant extra data or battery when running in the back

3. Always check if your internet and Bluetooth is on. Ensure inside the Bluetooth settings of your smartphone, that your smartphone is connected to the “smart system eBike”.

4. For Android smartphones, please also enable location services.

5. Check the state-of-charge of your smartphone. If necessary, charge your smartphone. For Android please also check the battery saving mode settings on your smartphone. If this setting is enabled, Bluetooth will be turned off.

6. Switch the eBike and the Smartphone off and on again.

7. Is the Flow app telling you to "forget" the device?
Then do the following:

  • Go to your phone's Bluetooth settings

  • Find smart system eBike in the list of devices

  • Tap on the i or cog icon on the right

  • Select Forget this device and confirm

Then pair via the eBike Flow app again (see here).

8. If this still doesn’t solve the problem, you can also remove your eBike inside the Flow App.
Go to  Settings > My eBike > Reset & remove > Remove eBike.
Be aware: Removing the eBike inside the Flow App will also remove custom settings like custom riding modes.

If you have problems connecting your eBike for the first time, please find troubleshooting’s here.

Tell a friend

Share link

Was this helpful?

Any questions?
We're happy to help.

Contact

Help Center

Any questions?
We're happy to help.

Contact