Back

What are the minimum requirements for my Apple Watch for use with the eBike Flow app?

The eBike Flow App requires at least watch OS 7.1. This requires a Series 3 Apple Watch or newer.

Tell a friend

Share link

Any questions?
We're happy to help.

Contact

Help Center

Any questions?
We're happy to help.

Contact